ERROR: There was a problem uploading the user corpus

WARNING: Error during file: /tmp/tmp_ut4y4cu/tests.tgz upload: {‘message’: ‘Request too large.’, ‘status_code’: 413}

83WARNING: uploaded user corpus None

84ERROR: There was a problem uploading the user corpus.

I tried different tags such as duration, and max_length and still get this error. Can we change the upload limit?

Hi @prateekvishnu, could you share the repository you are trying to integrate? It’s possible that this repository already has a /tests directory. When Mayhem runs, it looks for a tests directory and uses that as an initial seed corpus. If there are too many files (tests) in that directory, it may fail to run. duration refers to the overall fuzzing time, and max_length refers to the size of an individual test case, so I wouldn’t expect either of these to have an effect.

@abrewer Here is the repository: GitHub - paupino/rust-decimal: Decimal number implementation written in pure Rust suitable for financial and fixed-precision calculations..

Yes, it does have tests.

Out of curiousity, could you see if specifying an empty tests parameter gets you unstuck?
https://mayhem.forallsecure.com/docs/reference/mayhemfile/#tests
Something like:

tests:
  - file:

I don’t think that worked.

Ok, let’s just try an empty test directory. In your Dockerfile, something like:

RUN mkdir -p /home/mayhem/tests

And then in your Mayhemfile:

tests:
  - file:///home/mayhem/tests

This works. Thank You